Ankündigung

Einklappen
Keine Ankündigung bisher.

Erster XCopter Problem mit Motor4 an kk Board

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Erster XCopter Problem mit Motor4 an kk Board

    Schönen guten Tag zusammen,
    ich lese nun schon eine ganze zeit hier heimlich mit und nun ist es so weit dass ich auch mal was poste
    Vor ein paar Wochen wurde mir mein XCOPTER geschenkt und mittlerweile steht er nach einem langem Leidensweg zusammengebaut neben mir auf dem Schreibtisch.
    Aber alles der Reihe nach:

    Alles fing mit einer Anleitung an, die jedes Grundschulkind besser hingekriegt hätte..... Schwarz Weiß Bilder ohne hilfreichen Text. Als alter Bastler hat mich das aber nur wenig gestört, und es wurde munter drauf los gebaut bis ich zu dem Punkt kam wo ein Großteil der Schrauben fehlte. Ersatzschrauben waren schnell organisiert und das Grundgerüst stand innerhalb eines Nachmittags. Die Verkabelung gestaltete sich etwas schwieriger, weil die Kabel in der Anleitung alle grau, grau und grau waren. Google konnte mir bei diesem Problem helfen und der Copter wurde an das Board und den Empfänger angeschlossen. Super dachte ich, nun kann es losgehen! Allerdings habe ich die Rechnung ohne die kleinen Chinesen gemacht, die das kk Black Board 5.5 ohne Firmware geliefert haben. Bis ich das gemerkt habe war das erste Wochenende zu Ende. Unter der Woche wurde dann nach einer funktionierenden Firmware für das Board gesucht und ein ISP Programmer organisiert.
    In der zwischen zeit wurden den Brushless Reglern der Gasweg beigebracht und das ein oder andere Kabel nochmal abgelötet und anders verlegt.
    Letztes Wochenende wurde schließlich die Firmware "XCOPTER V4.7 kk by kapteinkuk" geflasht und ausprobiert. Nun stehe ich vor dem Problem dass sich die Motoren 1, 2 & 3 bei 5% des Gaswegs anfangen zu drehen, motor 4 aber erst bei 80% anfängt sich zu bewegen. Zuerst dachte ich dass es irgendwie ein Problem mit dem Regler ist und habe einen Ersatzregler organisiert, mit dem das Problem aber auch auftritt.... Im netzt bin ich nach etwas suchen darauf gestoßen dass es ein bekanntes Problem mit dem kk Board in Verbindung mit der v4.7 Firmware ist. Laut einigen Foren soll das umkehren der Gyros dieses Problem beheben, dummerweise nicht in meinem Fall. Deswegen habe ich es mit der Firmware "XCopter v2.9 by Minsoo Kim" Probiert. Hier ist aber das Problem dass ich das Board nicht in den "Armed" zustand bekomme. Langsam fange ich wirklich an zu verzweifeln. Bin für jedem Tipp dankbar!

    Zusammenfassung für Leute die keine Lust haben viel zu Lesen.

    Hardware: XCopter
    Motor: 1000KV
    Regler: Hobbywing Skywalker 20A
    Board: KK Board v5.5
    Akku: 3s Lipo
    Funke: Graupner MX16

    Linker Knüppel Hoch / Runter: THR
    Linker Knüppel Links / Rechts: RODO
    Rechter Knüppel Hoch / Runter: ELE
    Rechter Knüppel Links / Rechts: AIL

    Software:
    1. XCOPTER V4.7 kk by kapteinkuk
    Fehler: Motor 4 Läuft nicht mit den anderen Motoren an (Gyros umkehren hat nicht geholfen, allerdings weiss ich nicht 100% ob ich den richtigen gyro gedreht habe!)

    2. XCopter v2.9 by Minsoo Kim
    Fehler: kk Board geht nicht in den "Armed" Zustand


    p.S.: Sollte ich das kk Board nicht bald zum laufen kriegen werde ich vorübergehend auf ein Ersatzboard umsteigen um den Frust etwas zu mindern. Zur Auswahl stehe das MultiWii SE und das APM2.5. Sehe ich das richtig, dass das Ardupilot board nur optional zu dem AMP2.5 gehört und nur benötigt wird wenn man die Autopilot Funktion nutzen möchte?
    Welches der zwei Boards könnt ihr eher empfehlen?
    Zuletzt geändert von x20011; 04.11.2013, 12:09.

  • #2
    AW: Erster XCopter Problem mit Motor4 an kk Board

    Hat wirklich keiner eine Idee?

    Kommentar


    • #3
      AW: Erster XCopter Problem mit Motor4 an kk Board

      Ja anderes board testen wäre das einfachste was man machen kann, um den rest auszuschließen.
      beste grüße

      Mein Hangar

      Kommentar


      • #4
        AW: Erster XCopter Problem mit Motor4 an kk Board

        Welches könnt ihr eher empfehlen?

        MultiWii SE
        Ardupilot Mega APM2.5

        Kommentar


        • #5
          AW: Erster XCopter Problem mit Motor4 an kk Board

          Ohne GPS sind die okay. Wenn du was easy haben willst Naza Lite.
          APM will ich mal mit externem Kompass testen, dann kann man mehr dazu sagen.
          Da alle Modelle nicht mehr aufzählbar sind, um sie hier zu zeigen.. Meine RC Modelle in Übersicht.
          Carbon Breaker, Carson Attack, FG Glattbahn, Reely Rex X, TS4-N Pro V2, AMG Mercedes.
          Facebook Google+ zuendy.de
          Willst du mir etwas gutes tun?

          Kommentar


          • #6
            AW: Erster XCopter Problem mit Motor4 an kk Board

            Zitat von zuendy Beitrag anzeigen
            Ohne GPS sind die okay. Wenn du was easy haben willst Naza Lite.
            APM will ich mal mit externem Kompass testen, dann kann man mehr dazu sagen.
            Gerade den Umbau auf den externen Kompass gemacht, bin jetzt von 70% auf 28% runter, allerdings ohne grosse Optimierung.
            (Ist auch bei 70% gut geflogen, zumindest hatte ich keine Probleme mit RTL)

            setup] compassmot
            This records the impact on the compass of running the motors. Motors will spin!
            Hold throttle low, then raise to mid for 5 sec, then quickly back to low.
            Press any key to exit.

            measuring compass vs THROTTLE
            thr:133 cur:0.00 mot x:-0.1 y: 0.0 z: 0.7 comp x:0.01 y:-0.00 z:-0.05
            thr:174 cur:0.00 mot x:-0.1 y: 1.0 z:-5.3 comp x:-0.68 y:-1.81 z:8.81
            thr:195 cur:0.00 mot x:-0.1 y: 2.0 z:-5.3 comp x:0.62 y:-3.58 z:18.00
            thr:316 cur:0.00 mot x: 1.9 y: 2.0 z:-19.3 comp x:-0.98 y:-5.68 z:29.73
            thr:427 cur:0.00 mot x: 4.9 y: 5.0 z:-31.3 comp x:-4.73 y:-7.94 z:43.57
            thr:478 cur:0.00 mot x: 8.9 y: 7.0 z:-35.3 comp x:-9.48 y:-10.36 z:56.34
            thr:587 cur:0.00 mot x:11.9 y: 8.0 z:-49.3 comp x:-13.16 y:-11.84 z:66.17
            thr:718 cur:0.00 mot x:18.9 y:12.0 z:-70.3 comp x:-17.03 y:-13.38 z:75.02
            thr:764 cur:0.00 mot x:20.9 y:13.0 z:-75.3 comp x:-20.61 y:-14.67 z:82.96
            thr:763 cur:0.00 mot x:19.9 y:13.0 z:-72.3 comp x:-23.04 y:-15.67 z:88.52
            thr:763 cur:0.00 mot x:18.9 y:13.0 z:-72.3 comp x:-24.37 y:-16.23 z:91.40
            thr:763 cur:0.00 mot x:19.9 y:13.0 z:-70.3 comp x:-25.04 y:-16.46 z:92.63
            thr:0 cur:0.00 mot x:-1.1 y: 3.0 z:-10.3 comp x:-23.25 y:-16.32 z:90.00

            Interference at full throttle is 28% of mag field

            Compass
            ----------------------------------------
            enabled
            Mag Dec: 1.4333
            Mag off: -15.0560, 85.2059, -5.1211
            Motor Comp: Throttle
            Comp Vec: -23.25, -16.32, 90.00


            Morgen geht´s raus zum testen .. aber das APM iss schon cool

            Kommentar

            Lädt...
            X